Damn Vulnerable iOS Application (DVIA)

A vulnerable app to test your iOS Penetration Testing Skills

Downloads

Posted 5 years ago by prateekg147

Swift Version (April, 2018) – Download the IPA file from here here
Github – Here
Make sure to read this for instructions on how to install the app on any device (jailbroken or not jailbroken), and how to compile the app with Xcode.

This version will only work on iOS 10 or later devices, older versions of iOS are not supported. This version supports 64 bit devices only.

Make sure to read this post on how to get started with using DVIA.

Objective-C version (November, 2016) – Download the IPA file from here

This version will only work on iOS 8 or later devices, older versions of iOS are not supported. DVIA supports both 32 and 64 bit devices as well.

Even Older Version
Download the deb file from here
Download the IPA file from here

Github – Here

For the Objective-C version, instructions to compile app for iOS 10 & Xcode 8 can be found here. Written by Andrew Hoog from NowSecure.com

Bookmark the permalink.